The New Bug Tracker

    You must be logged in and belong to this group to post to this forum.
    1 of 21
    Yermo
    5 years ago
    I'm getting bug reports on Facebook, in email, via text and here in the forum. I can easily keep track of these for myself but I want to be able to, just like with everything else, have discussions around them. 

    We could easily use a third party ticket list system, but I doubt many users would end up reporting problems because of the trouble involved.

    So keeping with the "integrate everything so we can talk about it here" theme, I've put together the beginnings of an issue tracking system that's integrated as a "shared object' meaning we can now do with bug reports/feature requests what we can do with photos, links, videos, comments, etc. 

    You will notice there is a new link at the very bottom of the page "Bug Reports". You can also go to the /tickets page at http://m-by-mc.com/tickets.html. I've also added a Report Bug tab onto the INSERT menu. 

    The bug tracker itself has some bugs, which I'll document. If you want to discuss bugs here in the forum,  for the time being reply to this thread. (For some reason, if you use the Report Bug tab in the first post of a thread the Submit Bug button doesn't work, but it does work in the reply to thread case. Go figure. I'll futz with it tomorrow.)

    Hopefully, this will provide a nice central place to keep track of bug reports and feature suggestions. Each bug has a number of settings including:

    . title
    . description - please provide as much information about how I should reproduce a given problem.
    . type - feature request, bug report, etc
    . priority - site is broken, it's a nuisance, it's minor
    . status - open, closed, etc

    Each bug also gets a comment thread where we can keep the discussion of the bug with the bug. 

    I'll go through the site and gather all the bugs I know about and enter them.

    (BTW, remember how I said that after these 7 months of intense effort that things would get quicker? I built all of this bug tracking system from scratch last night and today. Granted, it's rough, but it's a lot of stuff for such a short period of time.)
    2 of 21
    Yermo
    5 years ago
    Bug Report (5485)

    Submit Ticket Button on Report Bug Tab of forum INSERT dialog fails on first post

    If used in the first post of a thread the Submit Ticket button the Report Bug tab in the forum INSERT dialog does not work with a javascript console error of "not property msie of undefined".

    5 years ago byYermo
    Bug Report (5486)

    Multiple Notifications are being sent for the same event

    Reported by buffalo(https://miles-by-motorcycle.com/buffalo) and AGrip(https://miles-by-motorcycle.com/252) , multiple notifications are being generated for the same event. I have been able to reproduce this.

    5 years ago byYermo
    Bug Report (5487)

    The Bookmark dialog can grow too large

    When bookmarking a large post, the bookmark dialog can extend off the screen.

    5 years ago byYermo
    Bug Report (5488)

    User Menu - email notifications settings

    rshaug(https://miles-by-motorcycle.com/261) reported: When selecting "e-mail notification" from the dropdown menu of the username, the attached page is displayed. #bug 1.Browser: Chrome Version 25.0.1364.172 m java console gives this error: "GET http://pagead2.googlesyndication.com/pagead/show_ads.js " 2. OS: windows 7 3. steps required to reproduce the problem: per bug description 4, If you were given a "formVIsta' error please jot down the error number so I can look it up in the logs: NA I have not yet been able to reproduce this bug.

    5 years ago byYermo
    Bug Report (5489)

    Add Photos Produces Error

    rshaug(https://miles-by-motorcycle.com/261) reported: Adding photo inline into reply on bug thread threw a bug. #bug FormVista Error: formVista ERROR #31209:We are sorry but that has been a system error. {"files":[{ "error":"", "name":"", "size":"", "url": "", "thumbnail_url": "", "delete_url": "", "delete_type": "DELETE" }]} I have not been able to reproduce this bug.

    5 years ago byYermo
    Bug Report (5490)

    Notifications Drop Down not formatting correctly

    Reported by buffalo(https://miles-by-motorcycle.com/buffalo) When I click on the notifications character by my avatar, I get an ordered list of notifications, but the text doesn't fit in the boxes quite right. Also, once I click on the notifications character, I can't get back to it (the notifications listing) until I get new notifications.This is in firefox 19/win xp

    5 years ago byYermo
    Bug Report (5492)

    Quotes in Photo Titles

    Reported by buffalo(https://miles-by-motorcycle.com/buffalo) When putting quotes in the title of a photo for upload, I got this error: Error SyntaxError: JSON.parse: expected ',' or '}' after property value in objectand the upload failed. When I escaped the quotes with backslashes, the upload worked.firefox 19.02, winXP. #bug

    5 years ago byYermo
    Bug Report (5493)

    Search box incorrectly searches on whitespace

    Searching using members or hash tags in the search dialog fails if any spaces are included.

    5 years ago byYermo
    Bug Report (5494)

    Tag and Member dropdowns disappear if mouse used

    In the search box if a users selects a tag or member from the dropdown using the mouse the dropdown disappears and clears the selection. This is due to jquery autocomplete interfering with the search box I think.

    5 years ago byYermo
    Bug Report (5495)

    Photos uploaded in a group are all tagged with the title and description of the first one

    reported by buffalo(https://miles-by-motorcycle.com/buffalo) and AGrip(https://miles-by-motorcycle.com/252) When uploading several photos at one time, the first photo label and description are used for ALL of the photos uploaded, ignoring titles and descriptions provided for the rest of the pictures. This bug has been fixed and the fix has been fielded. If you notice this problem again please let me know.

    5 years ago byYermo
    Bug Report (5496)

    Can't Log in Using MSIE 9

    reported by Gabe(https://miles-by-motorcycle.com/371) In addition to the bug I mentioned to you prior (carriage returns missing using Firefox), found a new one - can't log in using IE9. #bug IE9 - 9.0.8112.16421 Update versions: 9.0.14 (KB28909289) Windows 7 Professional. Attempted to log in using e-mail address and password using the top right "login" hyperlink... nothing happens. Password vanishes and the dialog (login prompt) remains there. - Gabe EDIT UPDATE: For the IE9 bug - upon clicking elsewhere, it looks like a login was successful even though the dialog did not go anywhere. I appear to be logged in. This may be part of a larger bug. I'm seeing intermittent login problems but have not yet narrowed down the exact case.

    5 years ago byYermo
    Bug Report (5497)

    Forum Post Edit Dialog does not close under MSIE

    reported by Gabe(https://miles-by-motorcycle.com/371) The dialog window for editing a forum post of mine does not vanish or update the window. However upon X'ing or cancling the dialog window out, if I refresh (reload) IE9 for that page I can see the update took. Sounds similar to the prior bug to me.

    5 years ago byYermo
    Bug Report (5498)

    Carriage Returns and Backspace working inconsistently in rich_textarea

    reported by Gabe(https://miles-by-motorcycle.com/371) The post dialog editor behavior is inconsistent using carriage returns and backspaces. I've been able to replicate the behavior on Windows 7 Pro. using: IE9 - 9.0.8112.16421 Update versions: 9.0.14 (KB28909289) Chrome Version 25.0.1364.172 m Carriage returns often double-space... multiple backspaces (sometimes no amount of backspaces) will go back to the line above. However this works just fine in Firefox 19.0.2.

    5 years ago byYermo
    Bug Report (5499)

    Cursor movement problems in rich_textarea

    reported by Gabe(https://miles-by-motorcycle.com/371) The arrow keys for navigating the cursor for IE9 and Chrome (versions above) work properly. However in Firefox 19.0.2 when entering text in the dialog box, the cursor keys do not function... it's like the OLD days where you had to find a way to move the cursor creatively (cringe). Should be easy to replicate using the description.

    5 years ago byYermo
    Bug Report (5500)

    Ugly Error Message on Mis-formed tag

    reported by Gabe(https://miles-by-motorcycle.com/371) misformed tags generate an ugly error message instead of cleanly providing feedback to the user that the tag is misformed. We may want to allow numeric tags even if twitter does not.

    5 years ago byYermo
    Bug Report (5500)

    Ugly Error Message on Mis-formed tag

    reported by Gabe(https://miles-by-motorcycle.com/371) misformed tags generate an ugly error message instead of cleanly providing feedback to the user that the tag is misformed. We may want to allow numeric tags even if twitter does not.

    5 years ago byYermo
    Bug Report (5501)

    The site is bloody slow

    reported by everyone. formVista is taking way too much memory and way too much time to generate pages. This is party due to the overly flexible permissions system I've built which is causing too many object retrievals. My plan is to simplify the permissions/privacy system to reduce the amount of objects that have to be queried to determine if a given member is allowed to see a given object. The second part of this is to implement a more efficient parser for my custom markup language, FVML, which all this stuff is written in. I suspect this ticket will just be left open for the life cycle of the site since performance will be an ongoing struggle.

    5 years ago byYermo
    Bug Report (5501)

    The site is bloody slow

    reported by everyone. formVista is taking way too much memory and way too much time to generate pages. This is party due to the overly flexible permissions system I've built which is causing too many object retrievals. My plan is to simplify the permissions/privacy system to reduce the amount of objects that have to be queried to determine if a given member is allowed to see a given object. The second part of this is to implement a more efficient parser for my custom markup language, FVML, which all this stuff is written in. I suspect this ticket will just be left open for the life cycle of the site since performance will be an ongoing struggle.

    5 years ago byYermo
    Bug Report (5502)

    Posting PDF links to rich_textarea fails

    originally reported by buffalo(https://miles-by-motorcycle.com/buffalo) For some reason the editor really didn't like my attempted post of a .PDF article link on from bmwbmw.org--it gave me multiple permission and validation errors when I tried to post. I did make sure there was space before and after the link.

    5 years ago byYermo
    Bug Report (5503)

    Posting some google maps links fail in rich_textarea

    reported by rshaug(https://miles-by-motorcycle.com/261) Some google maps links cause a ERROR graphic not found. http://www.facebook.com/l.php?u=http%3A%2F%2Fgoo.gl%2Fmaps%2FZtVIg&h=cAQG6dUBn

    5 years ago byYermo
    Bug Report (5504)

    Newlines in FireFox not being handled correctly especially with copy and paste

    reported by Gabe(https://miles-by-motorcycle.com/371) when copying and pasting text into rich_textarea in firefox newlines are stripped. Newlines seems to be stripped in other circumstances as well under FireFox.

    5 years ago byYermo
    3 of 21
    Yermo
    5 years ago
    Bug Report (5506)

    Facebook chooses awkward titles for M-BY-MC links shared there

    Links to M-BY-MC shared on Facebook show up with messed up titles and descriptions. Simply share a link on Facebook to see this.

    5 years ago byYermo
    4 of 21
    Yermo
    5 years ago
    I forgot to mention, you can search for bugs from the advanced search link in the upper right.
    5 of 21
    Yermo
    5 years ago
    So I know of 27 bugs and feature requests. It's not quite as many as I had thought. Only a few are blockers.

    It's been a long day. Goodnight. all.  
    6 of 21
    buffalo
    5 years ago
    When attempting to post some links in this thread:http://miles-by-motorcycle.com/5757-5760/trail-and-dirt-riding-in-maryland#o_5760everything got globbed together (CentOS, firefox 17.05)
    7 of 21
    buffalo
    5 years ago
    And my bug post above just had the same problem
    8 of 21
    Yermo
    5 years ago
    Ah, yea. I've got a FireFox bug with the way they handle newlines. I think it's related to this bug.

    Bug Report (5504)

    Newlines in FireFox not being handled correctly especially with copy and paste

    reported by Gabe(https://miles-by-motorcycle.com/371) when copying and pasting text into rich_textarea in firefox newlines are stripped. Newlines seems to be stripped in other circumstances as well under FireFox.

    5 years ago byYermo
    9 of 21
    rshaug
    5 years ago
    New #bug After editing a post (the new rain gear post) and saving a new thread was created of the edited content and the original remained. Now there are two threads, the original and the edited.
    10 of 21
    Yermo
    5 years ago
    Ok, thanks for pointing that out. I'll try to reproduce it here.
    Bug Report (6210)

    New Thread Edit Duplication

    Reported by rshaug(https://miles-by-motorcycle.com/261) New #bug After editing a post (the new rain gear post) and saving a new thread was created of the edited content and the original remained. Now there are two threads, the original and the edited. May be related to Chrome on Android.

    5 years ago byYermo
    11 of 21
    Gabe
    4 years ago
    Using Firefox 27.0.1, attempted to post a consumer reports article, saved the URL in it and clicked submit. Immediately received a blank white page with "No." in it and the following URL:

    http://miles-by-motorcycle.com/_fvc

    No.

    The Source code for the page said:

    <h1>No.</h1>


    Hit browser back, re-typed & re-submitted with no problem... only time I've seen this to date.
    12 of 21
    Yermo
    4 years ago
    Ok, that one's weird. I'm going to have to see if I can reproduce that one.
    13 of 21
    blalor
    8 months ago
    The /tickets link doesn't work, and I don't see a "bug report" link at the bottom.  I get:

    formVista ERROR #10013468:We are sorry but that has been a system error.formVista ERROR #10013469:We are sorry but that has been a system error.

    I was going to report a bug that adding emoji in a reply causes a 500…
    14 of 21
    Yermo
    8 months ago
    Thanks for the report. I need to re-develop the bug ticket system. It's been broken for ages. Internally, I moved to a different bug tracker.

    Was there anything else in the post other than text and the emoji? 
    15 of 21
    blalor
    8 months ago
    Just some words.
    16 of 21
    Yermo
    8 months ago
    huh, weird. What kind of device? phone? computer? What browser?
    17 of 21
    blalor
    8 months ago
    Safari Version 11.1 (13605.1.33.1.2) on macOS 10.13.4 (17E199).  A one-emoji post consisting of just a party popper causes an error. https://emojipedia.org/party-popper/

    Error
    An error has occurred.
    There has been a system error. (ERROR 10020636)
    18 of 21
    Yermo
    8 months ago
    Oh, so it's a system emoji. Hmmm. Ok. That's a problem. Thank you for pointing that out.
    19 of 21
    Yermo
    7 months ago
    blalor, thanks again for the bug report. It turns out that it pointed to something fundamental I missed. The upshot is that you should now be able to type in extended UTF8 emojis to your hearts content. 

    🤘🖐✊✋👊👌👍👎

    I suspect we should probably detect emojis somehow and apply some colors and maybe sizing to them, but that'll have to wait for some other time.

    For more colorful emojis, you can use the gif/png emojis I support directly here via the emoji button at the bottom of the reply dialog. 

    20 of 21
    blalor
    7 months ago
    Yermo wrote:
    blalor, thanks again for the bug report. It turns out that it pointed to something fundamental I missed. The upshot is that you should now be able to type in extended UTF8 emojis to your hearts content. 

    🤘🖐✊✋👊👌👍👎

    I suspect we should probably detect emojis somehow and apply some colors and maybe sizing to them, but that'll have to wait for some other time.

    For more colorful emojis, you can use the gif/png emojis I support directly here via the emoji button at the bottom of the reply dialog. 



    🎉

    Aren't emoji just characters?  Why go to the trouble of styling them?  Just let the browser display them natively.
    21 of 21
    Yermo
    7 months ago
    In my testing, it just looks like they are all being entered in the standard grey color so don't stand out very much as in my post above. Please give it a try and let me know what you think.
      formVistaTM By: Flying Brick Software, LLC
      formVista generated this page in: 0.2358 seconds
      using '6291456' bytes of memory