Sorry about the notifications bug/problems. Subscribe to this blog RSS Feed
    You must be logged in and belong to this group to post to this forum.
    1 of 1
    Yermo
    3 years ago
    I got reports from a few people yesterday that they were getting emails letting them know a notification was pending but then when they logged in to get the notification the box said they were not logged in.

    Needless to say, that was confusing.

    It turns out that there was a nasty bug that caused a notification to get sent out to all friends when it shouldn't have. So you may have gotten a notifications about a Gravel Ride that Ben Mendis and I were talking about (I was demoing the the 'schedule a ride and invite your friends' feature I had built and it sent out a notification about that ride to everyone in my friends list ... which it should not have.)

    The same happened when America.Rides.Maps and I were tracking down some other issues and he created a test ride.

    The upshot is that it should be fixed now. Thank you very much to mikesimsr, buffalo, and AGrip for helping me figure this one out.
    It was hugely helpful.

    The site has gotten pretty big and there's a huge amount of software that I've written to make it all work. I'm building all of this by my lonesome, so I often don't know when things break or when users run into trouble. So if you see some error message or something doesn't look like it's working right or it's not clear what I was thinking when I built a particular feature (especially with the maps, the ride plans, and the rides), please shoot me a message or post here in the forum. The feedback and conversations are incredibly helpful and I appreciate each and every one of them. 

    Thanks for being here. 
      formVistaTM By: Flying Brick Software, LLC
      formVista generated this page in: 0.4351 seconds
      using '4194304' bytes of memory